Issue concerning stack install of tidalcycles

#1

I installed ghc and cabal using stack. I also installed tidal with stack.

When I’m running ghci inside the containing folder of the ghci boot script, and I try to import Sound.Tidal.Context, it works fine.
However, when I set the ghci path in the tidalcycles atom plugin to that same ghci script, I can’t import
Sound.Tidal.Context.
Is it something to do with how the path for modules are set in haskell? I’m sure it’s an easy fix, I just don’t know where to look.

Running manjaro i3

0 Likes

#2

Sounds like you need to add something like this to the end of your .bashrc file:

export PATH="/path/to/where/your/ghci/is:$PATH"`

You’ll need to log out and log back in again for that to take effect.

Alternatively, changing the ghci path setting in the atom preferences for tidalcycles to stack ghci would likely do the job.

0 Likes

#3

I tried adding the path in .bashrc, and I still can’t import Sound.Tidal.Context.
As for changing the ghci path, my current path is
/home/will/.stack/programs/x86_64-linux/ghc-tinfo6-8.6.4/bin/ghci.
This is the same ghci that can import Sound.Tidal.Context when run on its own from a terminal,
but won’t import from inside Atom.

0 Likes

#4

Nevermind. I realized I had set up an alias for ghci, and it was the alias that was running, not the script.
I made the alias execute instead, and now everything’s fine.

0 Likes